Qtranslate no soportado en mi versión WordPress?

Despues de actualizar tu versión de WordPress puedes encontrarte que diferentes componentes (plugins) y widgets dejan de funcionar correctamente.

En el caso que nos ocupa Qtranslate, (el conocido sistema para hacer multiidioma tu web en WordPress) no esta exento de estos problemas e incompatibilidades de versiones.

Puede ocurrir que tengas la última versión de Qtranslate y que no haya todavía una versión actualizada para la nueva versión de WordPress que acaban de publicar… Como consecuencia, tu editor de páginas con las pestañas de idioma deja de funcionar y aparece el siguiente mensaje:

“The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version”

¿Como solucionar ésto?

Pues una opción “temporal” es editar el fichero qtranslate.php que encontrarás en la carpeta del plugin y donde pone :

sustituye la versión ’3.7.1′ por la versión que tengas del WordPress (en nuestro caso fue cambiarla  a la 3.7.2 ya que no habia una versión qtranslate que soportara dicha versión)

Una vez guardados los cambios y publicado de nuevo el archivo, observarás que aparecen nuevamente tus pestañas en el editor de tu WordPress.

Etiquetado con: , , , , ,
Publicado en: Trucos